Sim Network Connectivity

Incident Report for ClenergyEV

Resolved

Affected sims have now reconnected. We will continue monitoring but closing this issue now.
Posted Sep 17, 2026 - 14:29 UTC

Update

The issue has been narrowed to WirelessLogic sims. We're awaiting an update on this. Other sim providers and mobile networks in general are fine.
Posted Sep 17, 2026 - 14:13 UTC

Monitoring

There has been an issue identified with some mobile networks in the UK. We are monitoring the issue and will update here once we know more.
Posted Sep 17, 2026 - 13:57 UTC
This incident affected: Infrastructure (Clenergy EV Sim Network).